
THE REAL BLACK PANTHER

STEM PROJECTMIDDLE SCHOOL

In this packet, sample student answers are provided in red and notes to teacher are in blue.

In this STEM Project, students will expand their computing skills by following step-by-step 
instructions to code a model of natural selection into a database program (e.g. Microsoft Excel). 
They will use the model to investigate how changes in variables will affect predicted outcomes. 
Note: The teacher materials allow you to provide students with as much information as needed to 
modify the difficulty of the programming.



 

 

Scientists use many types of models. Some models are physical, and represent objects in the 
real world. An example is a model of a cell that allows people to see very small things that 
cannot be seen by the human eye. Similarly, a physical model of the environment can make 
huge objects or areas small enough to easily see and manipulate. A globe is one example. 
Alternatively, some models are mathematical. These models use equations to represent 
processes that occur in nature. They can be used to predict the behavior of systems or 
organisms. Computers can help make complex mathematical calculations. Scientists can also 
use computers to create simulation models. These are digital models that let us predict what 
might happen in the real world!

Let’s use a computer spreadsheet to create a simple simulation model of evolution to explore 
the possible bene�ts and costs of a leopard having a black coat. This model will not be 
completely realistic or accurate, but it will provide some ideas on how evolution might work.

The �rst step is to create the mathematical equations that we will use to represent processes. 
The next step is to write the code into a computer program. For this exercise, we will use a 
spreadsheet for our computer program. The �nal step is to use the program to explore 
different scenarios.

Here is the simpli�ed scenario we will use in our model:

1. A population of leopards has individuals with black coats and yellow coats.

2.  The number of adult black panthers at the start of each year is called the 
“Number of Black Adults.” At the start of the �rst year, there are 50 black adults.

3.  The number of adult yellow panthers at the start of each year is called the 
“Number of Yellow Adults.” At the start of the �rst year, there are 250 yellow adults.

4.  The color of a leopard’s coat is controlled by one gene.

5.  The allele for a yellow coat is dominant. The allele for a black coat is recessive.

6.  In each year, 70% of black panthers survive to reproduce that year (Adult Survival 
Rate Black = 0.7).

7.  In each year, 80% of yellow leopards survive to reproduce that year (Adult Survival 
Rate Yellow = 0.8).

8.  Every year, each individual that starts the year produces three offspring (cubs per 
adult = 3).

9.  Black panthers’ cubs are 25% black (Proportion black cubs by black adults = 0.25) 
and 75% yellow (Proportion yellow cubs by black adults = 0.75).

10. Yellow panthers’ cubs are 10% black (Proportion black cubs from yellow adults = 0.10) 
and 90% yellow (Proportion yellow cubs from yellow adults = 0.90).

11. Twenty-�ve percent of black panther cubs survive to be an adult in the next year
(Black Cub Survival Rate = 0.25).

12. Twenty-�ve percent of yellow leopard cubs survive to be an adult in the next year 
(Yellow Cub Survival Rate = 0.25). 2
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ACTIVITY 1: CREATING EQUATIONS 
The next step of creating a model is to develop the equations that we need to program 
the computer. Use the symbols given in Table 1 to fill in equations 1-12 on the next 
page.

Table 1. Computer program equation spreadsheet

Description Symbol Value if
Constant

Initial number of black panther adults at start of a generation NBI

Black panther adult survival rate SAB 0.70

Number of black panther adults that survive to reproduce NBR

Initial number of yellow leopard adults at start of a generation NYI

Yellow leopard adult survival rate SAY 0.80

Number of yellow leopard adults that survive to reproduce NYR -

Total number of black panther cubs produced by adult black panthers BCB -

Total number of yellow leopard cubs produced by adult black panthers YCB -

Total number of black panther cubs produced by adult yellow leopards BCY -

Total number of yellow leopard cubs produced by adult yellow leopards YCY -

Total number of cubs produced by each adult CT 3

Proportion of black panther cubs produced by black panthers PCB,B 0.25

Proportion of yellow leopard cubs produced by black panthers PCY,B 0.75

Proportion of black panther cubs produced by yellow leopards PCB,Y 0.10

Proportion of yellow leopard cubs produced by yellow leopards PCY,Y 0.90

Survival rate of black panther cubs SCB 0.25

Survival rate of yellow leopard cubs SCY 0.25

Total number of yellow leopard cubs surviving to adulthood NYC -

Total number of black panther cubs surviving to adulthood NBC -

Number of black panther adults at end of generation  
(and start of next) NBE -

Number of yellow leopard adults at end of generation  
(and start of next) NYE -

Total number of leopards at end of generation (and start of next)  LT -

-

-

-



1.  NBR = SAB * NBI

2.  NYR = SAY * NYI

3.  BCB = NBR * CT * PCB,B

4.  YCB = NBR * CT * PCY,B

5.  BCY = NYR * CT * PCB,Y

6.  YCY = NYR * CT * PCY,Y

7.  NYC = SCY * (YCB + YCY)
8.  NBC = SCB * (BCB + BCY)
9.   NBE = NBC + NBR

10. NYE = NYC + NYR

11. LT = NBE + NYE

12. Proportion of black panthers at the end of the generation = NBE/LT

 We will call this PBP in the spreadsheet.

ACTIVITY 2: CREATING A SIMULATION PROGRAM 

Our next step is to put these equations into a spreadsheet.  

Step 1: Getting started 

1. Open your spreadsheet program. In order to not lose your work, save your spreadsheet to your 
favorite folder. You can click the disk icon at the top of the page or click on File -> Save As. 

2. Give the file the name “panther_simulation.xslx”  Make sure you save your sheet frequently 
while you work! 
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Step 2: Insert the constants

Within simulation programs it is useful to see what happens when values change in the 
model. This requires a place to save all of the constants that we might want to change. 

1. In cells A1 to I1, enter the names of the symbols for the factors that have defined values 
in Table 1. Put the subscripts in parentheses. 

2. Enter the values for each of these constants in cells A2 to I2. 

Step 3: Set up the headings 

1. In Cell A5, enter the word “Generation.” In the rows below this heading we will enter 
number of times the panthers go through a cycle of survival and reproduction. 

2. Enter the symbols for the values that need to be calculated from questions 1-12 in 
Activity 1 in Cells B5 to N5.
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3. Enter the numbers 1, 2, and 3 in cells A6, A7, and A8 respectively. 

4. Click and hold on cell A6 and drag down to highlight cells A6-A8. Release the click.  

5. Put the cursor in the lower right corner of cell A8 on the small black square. 

6. Click and hold, then drag the cursor down through Cell A20 and release. It should 
look like this: 

                       

Step 4: Entering the equations 

1. In cell B6 enter the starting number of black panthers in Activity 1 (50).

2. In cell D6 enter the starting number of yellow leopards in Activity 1 (250).

3. Fill in the equation to calculate NBR in cell C6. Do this using the cell locations where you 
stored constants or where cells have the information you need. Here, and for the rest of 
the activity, if you are using one of the constants, put a $ in front of the column number 
and a $ in front of the row number. For cell C6, the formula should be: 

                         
                    

 =$A$2*B6
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4. Fill in the equation to calculate BCB in cell F6. Remember the dollar signs. 

=C6*$C$2*$D$2 

5. In the space below, write out the equation that you need to enter into cell G6 to 
calculate YCB 

=C6*$C$2*$E$2 

6. Enter the equation you wrote above in Cell G6. 

7. In the space below, write out the equation that you need to enter into cell E6 
to calculate NYR.

=$B$2*D6

8. Enter the equation you wrote above in Cell E6 

9. In the space below, write out the equation that you need to enter into cell I6
to calculate YCY.

=E6*$C$2*$G$2
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What’s with the dollar signs? These tell the computer that you want to always look at cell A2, even 
if you copy the formula somewhere else. If there are no dollar signs before the row and column 
designations, then if you copy the formula and paste it somewhere else the computer will change 
the letter and row numbers to match the selected cell. So, if I copied this formula from Cell C6 
(where it is written) and pasted it in Cell E12 (which I wouldn’t do) then the formula would 
become =$A$2•D12. You will see why writing the formula this way is important soon!  

In the questions below, students are asked to develop their own equations. This activity is best done 
together as a class to ensure students have the correct equations before they are input on the 
computer. Have students work in groups to develop their ideas. 

11. In the space below, write out the equation that you need to enter into cell H6
to calculate BCY.

=E6•$C$2•$F$2 

10. Enter the equation you wrote above in Cell I6 
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=$I$2*(G6+I6) 

=$H$2*(F6+H6) 

 

=K6+C6 

=J6+E6 

=L6+M6 

=L6/N6 
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12. Enter the equation from question 11 in Cell H6. 

13. In the space below, write out equation below to calculate NYC in cell J6. Notice 
the dollar signs and the parentheses to make sure the order of operations is 
correct!  

15. In the space below, write out the equation that you need to enter into cell K6 
to calculate NBC.  

16. Enter the equation you wrote above in Cell K6. 

17. In the space below, write out equation below to calculate NBE in cell L6. 

19. In the space below, write out equation below to calculate NYE in cell M6. 

21. In the space below, write out equation to calculate LT in cell N6.  

23. Enter the equation below to calculate the proportion of black panthers in the 
population at the end of the generation.

14. Enter the equation you wrote above in Cell J6. 

18. Enter the equation you wrote above in Cell L6. 

20. Enter the equation you wrote above in Cell M6. 

22. Enter the equation you wrote above in Cell N6. 

24. Enter the equation you wrote above in Cell O6. Label cell O5 as PBP.  



Now it’s time to set up the second generation. 

1. Copy cells B6 through O6. 
2. Move the cursor to cell B7 and paste the values. 
3. Delete the values in cell B7 and the value in D7. To do this, highlight the cell and 

hit the DELETE key. The rest of the values in the row should turn into 0s, except for 
O7 which becomes #DIV/0!. 

 

 

4. Now we need to enter a formula for the starting number of black panthers and 
yellow leopards in generation 2. Enter the formula “=L6” into cell B7. This sets 
the starting number of black panthers to the number that survived generation 1. 
In Cell D7, enter “=M6” to do the same for yellow leopards. 

Step 6: Complete the simulations  

Now, we need to see what will happen to the population in future generations.  
If you have put your formulas in correctly, this is easy!  

1. Select cells B7 through O7. 
2. Click and hold with the cursor on the black square in the lower right corner   

of cell O7. 
3. Drag the cursor down to select through cell O20. 
4. Release the cursor. Values should populate the entire sheet. 
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At the end of the �rst generation your students table should look like this.

Step 5: Set up the next generation
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Step 7: Creating the simulation tab

Now that we have our simulation complete, we need to be able to visualize our data.  
To do this we need to add another sheet to our project. 

1. Rename the current sheet. 
a. Double click on “Sheet 1” at the bottom. 
b. Type “Simulation” to replace the name. 

2. Click on the + next to “Simulation” to add another sheet. 
3. Rename Sheet 2. 

a. Double click on “Sheet 2” at the bottom. 
b. Type “Data” to replace the name. 
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Now let’s automatically move the data to the data sheet. 
1. Click on the sheet now labeled “Simulation.” 
2. Highlight Cells A5-A20. 
3. Go to the Edit tab at the top and click -> Copy tab. 
4. Click on the sheet called Data.
5. Put your cursor in cell A1. 
6. Go to the Edit tab at the top and click -> Paste.
7. Click on the Simulation sheet. 
8. Highlight cells L5 to O5 and copy them. 
9. Click on the Data sheet. 
10. Put the cursor in cell B2. 
11. Go to the Edit tab and click -> Paste. 
12. Put your cursor in cell B2 and type “=”. Then click on the Simulation sheet and click on 

cell L6. This means that whatever is in Cell 6 in the Simulation sheet will appear in 
B2 in the Data sheet. 

Now for the graphs! 
1. Click on the Data sheet. 
2. Highlight cells B1 through D16. 
3. Click on the Insert tab at the top of the page and highlight Chart, then select Line.
4. Click on your new line graph and move it below the data.
5. Double click on the Chart Title and change the title of the chart to “Number of 

Leopards through Time.” 
6. Highlight cells E1 through E16. 
7. Click on the Insert tab at the top of the page and highlight Chart, then select Column. 
8. Click on your new bar graph and move it next to the first graph you created.
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13. Click cell B2 in the Data sheet. Click and hold the black box in the lower right-hand corner,
 and drag the cursor down to cell B16. Release the click to �ll in the column. 

14. While the information in cells B2 - B16 are still highlighted, click and hold the black box 
in the corner and drag the cursor over to E16. Release to �ll in the rest of the data table. 

Step 8: Setting up the simulation

Step 9: Visualizing the data
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1. Describe happens to the number of black panthers and yellow leopards through time. 

My graph shows the numbers of both black panthers and yellow leopards goes up 

through time. 

2. Describe happens to the proportion of black panthers in the population through time. 

My graph shows the proportion of black panthers decreases but then mostly levels off.
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Paste the graphs from the Data sheet here: 
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Answers should include ideas about the birth rates being high relative to the death rates 
showing population increase. Black panthers, however, don’t survive as well as yellow 
leopards so their populations increasing more slowly. That means that the proportion of 
black panthers in the population is decreasing. 

4. Predict what would happen if you were to run your simulation for a longer period 
of time. Describe whether you think this realistic. Support your answer. 

The population would go up forever. No, this is not realistic. Eventually panthers would 
die more quickly or have less offspring. They can’t take over and cover the entire world. 

ACTIVITY 3: EXPLORING PATTERNS 
The great thing about your spreadsheet is that you can use it to test how the system will 
change if you change some of your constants. Let’s give it a try! 

1. Click the + at the bottom of the sheet. 
2. Double click on the tab labeled Sheet 3. 
3. Rename the sheet “Original Simulation”. 
4. Click on the Simulation sheet. 
5. Click on the small box at the far upper left above row one and to the left of column A.  

This will select the entire sheet. 
6. Go to Edit -> Copy. 
7. Click on the Original Simulation sheet.
8. Put the cursor in A1 and go to Edit -> Paste Special. 
9. Select Paste Formulas. 

Now your original data are saved! Save your file.  
We can now do some experiments. Let’s do the first one together. 
Our question: Will black panthers do better if black cubs survive at a higher rate than 
yellow leopards? 

Constant changed:  SCB 

Old value: 0.25  New Value: 0.80  
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3. Explain the patterns you see for the number of leopards of both colors and the 
proportion of black panthers.

Extend the lesson: Have the students modify or explain how they would modify their 
spreadsheets to add more generations to test their predictions in question #4. 
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How to make the change: 

1. Click on the Simulations sheet. 
2. Change cell H2 from 0.25 to 0.8. 
3. Click on the Data sheet. 
4. Copy the graphs and paste them below. 

Paste the new graphs from the Data sheet here: 
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1. Describe how greatly changing the survival rate of black cubs influenced how the 
total population grew. Suggest why you think this happened. 

Students should notice that the population of leopards grew even more quickly than before.  
This is because more baby black panthers grew up to reproduce every year. 

2. Describe how greatly changing the survival rate of black cubs influenced how the 
proportion of black panthers in the population changed through time relative to the 
first simulation. 

The proportion of black panthers in the population increased through time until reaching 
about 30% of the population compared to dropping to around 9% of the population 
when yellow and black cubs had the same survival rate. 

Now we will do one more together. Go back to your Simulation sheet and reset cell H2 
to 0.25. 

Our question: Will black panthers do better if black adults survive at a higher rate than 
yellow leopards? 

Constant changed:  SAB

 

Old value: 0.7  New Value: 0.95  

Describe the changes you made below:
 

1. I clicked on the Simulations sheet. 
2. I changed cell A2 from 0.7 to 0.95. 
3. I clicked on the Data sheet. 
4. I copied the graphs and pasted them below.
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Paste the new graphs from the Data sheet here: 

4. Describe how greatly changing the survival rate of black panther adults 
influenced how the total population grew. Suggest why you think this happened. 

Students should notice that the population of leopards grew even more quickly than before.
This is because more adult black panthers survived to reproduce every year. 
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5. Describe how greatly changing the survival rate of black panther adults 
influenced how the proportion of black panthers in the population changed 
through time relative to the other simulations. Suggest why you think this 
happened. Hint: think about the genetics! 

The proportion of black panthers in the population decreased through time until reaching 
about 16% of the population compared to dropping to around 9% of the population 
when yellow and black cubs had the same survival rate, or increasing to 30% when black 
cubs survived at a very high rate. This may happen because even though black panthers 
survive better than yellow leopards, yellow leopards produce far more yellow cubs than 
black cubs compared to black panthers that still produce many yellow cubs.  

Accept answers that discuss the dominant yellow trait relative to the recessive black 
coat trait. 

Now it is time for you to explore on your own! Start by resetting cell A2 to 0.70
on the Simulation sheet. 

Fill in the steps below: 

Our question:  Answer should be a reasonable change to the program. 

Constant changed:  Answer should be a reasonable change to the program. 

Old value: Should reflect value in original data New Value: Should be a possible 
number (i.e. proportion between 0-1 or rates between 0-1). 

Paste the new graphs from the Data sheet here: 
Should look similar to those above.

 

6. Describe how your change influenced how the proportion of black panthers in 
the population changed through time relative to the first simulation. 
Accept reasonable answers that follow from graphs. 

7. Describe how greatly changing the survival rate of black panther adults 
influenced how the proportion of black panthers in the population changed 
through time relative to the other simulations.  

Accept reasonable answers that follow from graphs.
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